Zidoo Z9x speelt file in slowmotion af met audio drop outs

Started by sandervg, January 21, 2024, 11:02:07

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

sandervg

Ik heb een lastig probleem: ik heb met Movavi Slideshow maker een kort bestand gemaakt bestaande uit een paar korte video's en wat foto's. Dit geexporteerd naar een 4K 60 fps MKV file. Deze speelt prima of op de computer en telefoon, maar op de zidoo speelt de file in slow motion af en het geluid wordt ook steeds onderbroken.

Enig idee wat de oorzaak is en hoe ik dit kan oplossen?
Stereo: Audio Note - 47 Labs - Auralic - Pel
HT: JVC - WLM - Velodyne - Arcam - Meridian

sandervg

Niemand enig idee waar ik het zou kunnen zoeken? Elke suggestie is welkom  ::)
Stereo: Audio Note - 47 Labs - Auralic - Pel
HT: JVC - WLM - Velodyne - Arcam - Meridian


riwi

Je zou met mediainfo eens kunnen kijken wat dat mov-avi tooltje ervan gemaakt heeft, kwa video en audio stream.

sandervg

@tonv Het AV forum heeft helaas geen reacties opgeleverd.

@riwi Goede suggestie! Even gekeken, maar weet niet goed hoe het te interpreteren en of er iets 'geks'mee is.

Iemand enig idee?

 
Stereo: Audio Note - 47 Labs - Auralic - Pel
HT: JVC - WLM - Velodyne - Arcam - Meridian

riwi

https://mediaarea.net/en/MediaInfo

Als je het tooltje mediainfo download. Even icoon op je desktop zeten. En je dropt de media file erop.

Je ziet dan welke codecs er exact gebruikt zijn. Je schiet daar niks mee op maar je zou dan in je movavi tool wat kunnen instellen waardoor hij wat simpelere codec levels gebruikt die de Zidoo (RTL1619D) wel kent.

dan krijg je zo iets :
Video
ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L4
Format settings                          : CABAC / 4 Ref Frames
Format settings, CABAC                   : Yes
Format settings, Reference frames        : 4 frames
Codec ID                                 : V_MPEG4/ISO/AVC
Duration                                 : 59 min 27 s
Bit rate mode                            : Constant
Bit rate                                 : 7 436 kb/s
Nominal bit rate                         : 10 000 kb/s
Width                                    : 1 920 pixels
Height                                   : 1 080 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 23.976 (24000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.150
Stream size                              : 3.09 GiB (92%)
Default                                  : Yes
Forced                                   : No
Color range                              : Limited
Color primaries                          : BT.709
Transfer characteristics                 : BT.709
Matrix coefficients                      : BT.709

En bv die Format profile en Format settings zijn dan interessant

sandervg

Hi, even gedaan en dit is het resultaat (je kunt veel weergave modi kiezen, maar hier stond iig formaatinstellingen e.d. op).

Is hier iets uit op te maken? (voor mij gaat dit boven m'n pet)
Stereo: Audio Note - 47 Labs - Auralic - Pel
HT: JVC - WLM - Velodyne - Arcam - Meridian

riwi

Ik gebruik meestal de text output om te copy/paste'n op een forum, maar screenshot van de html is OK.

Wat mij opvalt is het level High@L5.2 dat is nieuwer/hoger dan wat ik meestal zie (L4 voor HD streams), L5.1 heb ik ook wel eens gezien.
Daarnaast zie ik een idioot hoge overall bitrate van 304Mb/sec ; ik denk dat de Zidoo daarover hikt. Doorgaans blijft de bitrate bij UHD schijven onder de 100Mbit/sec en bij Bluray onder de 40Mbit/sec. Streams van Netflix/Amazon zitten zelfs rond de 20Mbit/s maximaal.

Bij de Dune (met dezelfde RTL1619DR chip) zie ik :
Video codecs: MPEG2, MPEG4, XVID, WMV9, VC1, H.264, H.265, H.265 10-bit, VP9, VP9 profile 2; support for very high bitrate video up to 100 Mbit/s and higher.

Dus die garanderen tot 100Mb/s en misschien nog wat meer als je mazzel hebt.

Dus ik zou zoeken naar een manier om in de movavi slideshow maker de bitrate te limiteren op iets wat daar in de buurt zit.


<edit>
Hier nog een nette tabel waarin de max bitrates staan per Level.
https://en.wikipedia.org/wiki/High_Efficiency_Video_Coding_tiers_and_levels
Dus met High@L5.2 zou er maximaal 240Mbit/sec mogen zijn, maar dan met 120fps beeld. Ik zou kijken of je hem naar L5.1 kan zetten met 60p beeld en max 160Mbit/sec al is dat ook al op (of over) het randje voor de Zidoo.

sandervg

Dank voor de hulp, Riwi! Wordt erg gewaardeerd! Ik denk dat je gelijk hebt en dat de bitrate het probleem is. Geen idee hoe ik die kan verlagen in Movavi, maar daar ik ga ik eens naar zoeken en wat googlen. Ik heb nu in ieder geval een aanknopingspunt waar ik het kan zoeken  :)
Stereo: Audio Note - 47 Labs - Auralic - Pel
HT: JVC - WLM - Velodyne - Arcam - Meridian

sandervg

Bij Movavi kan ik kiezen uit de volgende uitvoer formaten/codecs. Welke zou ik beter kunnen kiezen/uitproberen?

AVI met H.264
AVI met MPEG-4
MP4 met H.264
MP4 met MPEG-4
MOV
MPEG-1
MPEG-2
MKV
WMV
FLV
M2TX met H.264
WebM
OGV
SWF
AVI met MJPEG
MKV met MJPEG

AANVULLING: ik heb ook nog gevonden dat ik de kwaliteit kan kiezen. Ik heb nu de laagste kwaliteit gekozen. De bitrate verandert dan naar net boven de 40 Mb/sec maar nog steeds draait de film in slowmotion. Wel 'minder' slow, maar niet op normale snelheid. Zonder alle formaten te gaan proberen (mijn computer > 10 jaar oude computer is lang bezig met decoderen): welke formaten zouden het meest kansrijk zijn om een kans te geven?
Stereo: Audio Note - 47 Labs - Auralic - Pel
HT: JVC - WLM - Velodyne - Arcam - Meridian

riwi

Draait ie dan langzaam zonder te schokken?
Heb je misschien een 60p bestand gemaakt en draait de Zidoo het op 30fps af ?

AVI met H.264
MP4 met H.264

Zou ik mee beginnen als de mkv optie niet werkt.

sandervg

Ja, langzamer zonder schokken. Het geluid onderbreekt wel periodiek (zodat het geluid na de onderbreking weer in sync loopt met het beeld. De vertraging is met de lagere bitrate wel minder. Het is idd een 60p bestand, maar dat zou de zidoo moeten kunnen afspelen. Gaat ook niet 2x zo langzaam (ik denk 20% te langzaam of zo). Misschien is ruim 40 Mb/s nog steeds te veel voor de Zidoo. Ik ga de MP4 en AVI opties proberen.
Stereo: Audio Note - 47 Labs - Auralic - Pel
HT: JVC - WLM - Velodyne - Arcam - Meridian

sandervg

Net getest, maar de andere formaten geven geen verbetering  :(

Heel bizar. De film loopt vloeiend zonder schokken, als ik de tijd laat meelopen duren de secondes keurig een seconde. Als het geluid stopt, stopt te teller van de film ook (de film blijft keur in slowmotion doordraaien). Dat duurt een paar seconden en dan gaat de teller weer lopen en komt het geluid er ook weer bij. Bizar probleem.... Heb opgezocht en de Zidoo zou zonder problemen 40 - 50 Mbit/s moeten kunnen afspelen, dus daar lijkt het niet aan te liggen.
Stereo: Audio Note - 47 Labs - Auralic - Pel
HT: JVC - WLM - Velodyne - Arcam - Meridian

Gabor


sandervg

Quote from: Gabor on February 10, 2024, 09:14:48Zet het geluid eens op 48kHz ipv 44,1kHz.
Hoe bedoel je dat? Bij het maken van de film in Movavi? Of op de Zidoo?
Stereo: Audio Note - 47 Labs - Auralic - Pel
HT: JVC - WLM - Velodyne - Arcam - Meridian

riwi

Bij het maken van de audiotrack in movavi denk ik.
Ik heb verder ook geen ideeen meer.

Gabor

Bij de export van Movavi inderdaad. Misschien project settings oid, ik ben niet bekend met het programma. Het zou mij verbazen als daar het probleem zit, maar aan de andere kant komt 44,1kHz bij beeld niet zo vaak voor. Wellicht gaat de Zidoo of het Android OS daar niet goed mee om.

Ook opvallend is dat er een framerate bij de audio track wordt genoemd, audio heeft geen framerate. Maar misschien is dit een (foute) interpretatie van MediaInfo.

sandervg

Geprobeerd, maar ook op 48Khz gaat het niet beter  :(

Heb ook (willekeurig) een andere format gekozen: MKV met 'gratis codec' wat dat dan ook moge zijn, maar dan zie ik helemaal geen beeld, alleen geluid. Maar het geluid speelt wel prima af zonder vertraging :)

Misschien moet ik een keer alle uitvoerformaten uitproberen om te zien of er één bij zit die door de Zidoo ondersteunt wordt.

Zou het aanschaffen van een Nvidea shield of zo kunnen helpen? Misschien dat zo'n apparaat wat minder precies is aan het formaat etc?
Stereo: Audio Note - 47 Labs - Auralic - Pel
HT: JVC - WLM - Velodyne - Arcam - Meridian

Gabor

De tot nu toe gekozen codecs zijn echt niet zo exotisch, ook de Zidoo moet daar mee overweg kunnen. Als je wilt kan ik bij mij iets testen op mijn Z9x.

Anders even door Shutter Encoder opnieuw encoderen als test, output H264 -> mp4, video bitrate bijv op 5000, audio op 256.
Of uit Movavi een keer 1920x1080 proberen ipv 3820x2160, of 30fps ipv 60.

sandervg

@Gabor : dank voor het aanbod! Eigenlijk wel een goed idee om het op jouw Zidoo te proberen. Dan kan ik in ieder geval uitsluiten dat er bv. in mijn Zidoo iets verkeer ingesteld staat. Ik stuur je even een PM om email adressen uit te wisselen zodat ik via wetransfer naar je kan mail.

Nu even geen tijd, maar maar als ik weer even tijd heb, zal ik andere codecs, formaten etc. proberen. Ik heb helaas een > 12 jaar oude laptop , dus dat beestje loopt te puffen en te kreunen bij het maken van de videootjes :).
Stereo: Audio Note - 47 Labs - Auralic - Pel
HT: JVC - WLM - Velodyne - Arcam - Meridian

Gabor

Getest, de video's spelen hier ook niet goed, precies dezelfde problemen.
Ik heb ook als test het audiospoor verwijderd om enige invloeden daarvan uit te sluiten, dat mag ook niet baten. Ik zal nog een paar re-renders aanzetten met verschillende instellingen, maar dat wordt later deze week.

sandervg

Bedankt voor het testen!

Dan kunnen we (waarschijnlijk) uitsluiten dat mijn Zidoo niet goed functioneert of ik ergens (perongeluk) een gekke instelling heb aangezet. Het geluidspoor kunnen we ook uitsluiten. Bitrate ook denk ik: de laatste versie (die ik ook met Gabor heb gedeeld) zijn niet meer dan een normale UHD.... Mmmm... Het aantal mogelijke oorzaken wordt wel minder, maar wat is het volgende dat we zouden kunnen proberen uit te sluiten?
Stereo: Audio Note - 47 Labs - Auralic - Pel
HT: JVC - WLM - Velodyne - Arcam - Meridian