Htforum.nl

ITC Home Theater en studioFD => Producten en diensten van ITC Home Theater => Crystalio / PMS => Topic started by: svmnb on April 28, 2007, 15:55:58

Title: Gedeeltelijk opgelost: PMS MB100: Help, geen NFS en Samba
Post by: svmnb on April 28, 2007, 15:55:58
Met netwerken ben ik niet erg snugger, maar ik heb de handleiding in de startpost tot op de letter gevolgd. Zonder succes, want ik krijg Samba niet eens aan de praat, laat staan NFS.
Bij invoer van NFS share zie ik alleen deze melding: "The NFS server has not been found".

Firewall en virusscanner uitgezet.
Zelfs Samba werkt niet. Ik kan wel pingen naar de MB100.
Heeft iemand enig idee wat hier fout gaat? Ik heb wat screenshots gemaakt die hopelijk meer aan het licht brengen.

IP settings in MB100
(http://www.xs4all.nl/~nico512/temp/1.jpg)


IP settings PC
(http://www.xs4all.nl/~nico512/temp/6.jpg)



NFS shares met twee verschillende notaties (een en twee slashes). Beiden werken niet.
(http://www.xs4all.nl/~nico512/temp/2.jpg)
(http://www.xs4all.nl/~nico512/temp/3.jpg)



NFS sharing tabblad in verkenner.
(http://www.xs4all.nl/~nico512/temp/8.jpg)



Permissions NFS sharing in verkenner.
(http://www.xs4all.nl/~nico512/temp/9.jpg)



Algemene sharing tab. Ook als ik hier het vinkje bij "Share this folder over the network" weghaal, werkt NFS niet.
(http://www.xs4all.nl/~nico512/temp/7.jpg)


Unix service configuratie.
(http://www.xs4all.nl/~nico512/temp/5.jpg)



Unix maps configuratie.
(http://www.xs4all.nl/~nico512/temp/4.jpg)
Title: Re: PMS MB100: Help, geen NFS en Samba
Post by: eduard on April 28, 2007, 16:23:27
Pc en mb100 hebben beiden het zelfde ip adres dit is geen goed idee, je moet er 1 wijziggen.
Title: Re: PMS MB100: Help, geen NFS en Samba
Post by: jaco on April 28, 2007, 17:33:55
geen goed idee
Dat is een understatement..

Advies is juist, verander bijvoorbeeld het ip adres van de MB100 naar 192.168.001.201
Title: Re: PMS MB100: Help, geen NFS en Samba
Post by: svmnb on April 29, 2007, 12:54:04
Bedankt voor jullie reacties. Helaas helpt dit ook niet.
De netwerkkaart waarmee de MB100 is verbonden heeft IPnr. 192.168.1.200
Als ik in static IP settings van de MB100 het IPnr. 192.168.1.201 invoer, krijg ik ook geen verbinding. Wel kan ik pingen naar dit IP adres, dus de bekabeling lijkt in orde.
Bij gateway en DNS hoeft niets ingevuld te worden?

Hoe zit nu met de juiste notering van een NFS share in de MB100:
Eerste regel: //shares/NICO/DVD
Tweede regel: 192.168.1.200


Dit is de inhoud van IP config

        Host Name . . . . . . . . . . . . : Nico
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Unknown
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Marvell Yukon 88E8053 PCI-E Gigabit
Ethernet Controller
        Physical Address. . . . . . . . . : 00-18-F3-3A-5A-2B
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 10.0.0.150
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . :

Ethernet adapter Local Area Connection 3:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Marvell Yukon 88E8053 PCI-E Gigabit
Ethernet Controller #2
        Physical Address. . . . . . . . . : 00-18-F3-3A-63-C6
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 192.168.1.200
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . :
Title: Re: PMS MB100: Help, geen NFS en Samba
Post by: eduard on April 29, 2007, 13:30:14
Misschien moet je de snelheid aanpassen van je Ethernet adapter Local Area Connection 3 het kan zijn dat deze op auto staat. Begin is met 100mb full duplex, ik heb geen idee of de mb100 gigabit aan kan. Weet je zeker dat al je firewalls uitstaan (windows, viruscanner).

Probeer eens vanaf de dosprompt
ftp 192.168.1.201
of telnet 192.168.1.201 21 
Title: Re: PMS MB100: Help, geen NFS en Samba
Post by: svmnb on April 29, 2007, 14:26:43
Ik heb alle speed en duplex settings geprobeerd, telnet en ftp geven beiden een foutmelding.

C:\Documents and Settings\Nico Bos>telnet 192.168.1.201
Connecting To 192.168.1.201...Could not open connection to the host, on port 23:
 Connect failed

C:\Documents and Settings\Nico Bos>ftp 192.168.1.201
> ftp: connect :Unknown error number

Logfile van NFS server:
-------------------------------------------------------------------------

DATE       TIME         TASK       RESULT  ADDRESS         DESCRIPTION...

-------------------------------------------------------------------------

04-29-2007 14:44:28 MOUNT   FAILURE 192.168.1.201   //shares/NICO/Divx
04-29-2007 14:44:36 MOUNT   FAILURE 192.168.1.201   //shares/NICO/Divx
04-29-2007 14:44:40 MOUNT   FAILURE 192.168.1.201   //shares/NICO/DVD
04-29-2007 14:44:42 MOUNT   FAILURE 192.168.1.201   //shares/Nico/Guest/Divx
04-29-2007 14:44:44 MOUNT   FAILURE 192.168.1.201   /shares/Divx
04-29-2007 14:45:33 MOUNT   FAILURE 192.168.1.201   //shares/NICO/DVD
04-29-2007 14:46:43 MOUNT   FAILURE 192.168.1.201   //shares/NICO/Divx
04-29-2007 14:46:46 MOUNT   FAILURE 192.168.1.201   //shares/NICO/DVD
04-29-2007 14:46:50 MOUNT   FAILURE 192.168.1.201   //shares/Nico/Guest/Divx
04-29-2007 14:46:51 MOUNT   FAILURE 192.168.1.201   /shares/Divx
04-29-2007 14:55:18 MOUNT   FAILURE 192.168.1.201   //shares/NICO/Divx
04-29-2007 14:55:22 MOUNT   FAILURE 192.168.1.201   //shares/NICO/DVD
04-29-2007 14:55:24 MOUNT   FAILURE 192.168.1.201   //shares/Nico/Guest/Divx
04-29-2007 14:55:26 MOUNT   FAILURE 192.168.1.201   /shares/Divx

Deze services starten niet automatisch of zijn disabled. Staat hier misschien iets bij dat wel moet draaien?
(http://www.xs4all.nl/~nico512/temp/services.jpg)

Het lijkt er op dat ik geen geluk ga hebben met deze aankoop :(
Heeft iemand nog ideen waar ik naar kan kijken?

Title: Re: PMS MB100: Help, geen NFS en Samba
Post by: eduard on April 29, 2007, 22:17:10
Wanneer je de telnet test vergeet niet achter het ip adres de spatie en dan de 21
telnet 192.168.1.201 21

Ze eventueel voordat je gaat testen je andere netwerk kaart uit.
Weet je zeker dat je geen firewall of virusscanner met firewal hebt draaien.
Title: Re: PMS MB100: Help, geen NFS en Samba
Post by: svmnb on April 30, 2007, 12:03:31
Eindelijk maak ik wat vorderingen. :D

Nadat ik met een laptop binnen 5 seconden wl via samba kon connecten, begon ik te vermoeden dat er iets met een NIC aan de hand was. Ik heb een oude 3Com netwerkkaart bijgeplaatst. Deze werkt wel met smb shares. Ik weet niet wat er mankeert aan die onboard NIC's, maar daarmee werkt het niet. Ik begon al tamelijk wanhopig te worden, na zoveel verschillende dingen te hebben geprobeerd.

Straks ga ik alsnog NFS proberen aan de praat te krijgen, maar dit is alvast een grote overwinning. ;D
Iedereen bedankt voor de reacties!
Title: Re: Opgelost: PMS MB100: Help, geen NFS en Samba
Post by: svmnb on May 2, 2007, 16:31:00
Helaas heb ik NFS nog steeds niet aan de praat. Samba draait wel als een zonnetje.

Ik heb Win XP Pro US met servicepack2. Volgens de beschrijving hoeft het .msi bestand niet veranderd te worden voor installatie. Ik heb het hele proces zowel met als zonder 'gecracked' bestand geprobeerd en zag geen verschil.

Wat basics:
Mijn PC-naam is NICO en deze draait niet in een domain, maar in een workgroup.
Het IP nr. van de pc is 192.168.1.202
De NFS server draait en staat keurig in het rijtje met geladen services.
Ik heb diverse mappen geshared, waaronder mappen genaamd DVD en Divx. Share alleen onder NFS of NFS+Samba maakt niets uit.
Firewall en virusscanner staan uit.

De syntax voor het mounten werkt niet:
//shares/NICO/DVD@192.168.1.202

Er wordt gewoon geen NFS server gevonden. Heeft iemand een idee wat ik verder kan proberen?